Difference: DaveEvansSTEP09CRABserver (4 vs. 5)

Revision 52009/07/30 - Main.BristolDave

Line: 1 to 1
 
META TOPICPARENT name="Main.WebTopicList"
CVS repository

Current tests are based on "STEP09TrivialAnalyzer" that runs on the JobRobot? dataset. The script to make the configs and the script to submit them to all T2 sites listed in siteDB are located in my CVS UserCode? /DLEvans/STEP09.

Added:
>
>
Recent Problems with CRAB server glidein-2

jobs do not submit I try to submit

[CRAB]
jobtype                 = cmssw
scheduler               = glidein
server_name             = ucsd

[CMSSW]
datasetpath             = /QCD_pt_0_15/JobRobot_IDEAL_V9_JobRobot/GEN-SIM-RAW-RECO
pset                    = ../../../STEP09TrivialAnalyzer/test/step09TrivialAnalyzer_v2_cfg.py
total_number_of_events  = 100
events_per_job          = 10
output_file             = STEP09TrivialOutput.root

[USER]
return_data             = 0
copy_data               = 1
storage_element         = T2_US_UCSD
ui_working_dir          = T2_US_UCSD-test_210709
user_remote_dir         = test_210709/T2_US_UCSD
publish_data            = 0

[GRID]
CE_white_list =  osg-gw-2.t2.ucsd.edu, osg-gw-4.t2.ucsd.edu
SE_white_list =  srm-3.t2.ucsd.edu

I get after a long time

[cms-tas03] /home/dlevans/step09/CMSSW_2_2_10/src/STEP09/test/crab/test_210709 > crab -status -continue T2_US_UCSD-test_210709/
crab:  Version 2.6.1 running on Thu Jul 30 16:22:01 2009 CET (14:22:01 UTC)

crab. Working options:
        scheduler           glidein
        job type            CMSSW
        server              ON
        working directory   /home/dlevans/step09/CMSSW_2_2_10/src/STEP09/test/crab/test_210709/T2_US_UCSD-test_210709//

crab:  
ID     STATUS             E_HOST                               EXE_EXIT_CODE JOB_EXIT_STATUS 
--------------------------------------------------------------------------------------------
1      Submitting                                                                             
2      Submitting                                                                             
3      Submitting                                                                             
4      Submitting                                                                             
5      Submitting                                                                             
6      Submitting                                                                             
7      Submitting                                                                             
8      Submitting                                                                             
9      Submitting                                                                             
10     Submitting                                                                             

crab:   10 Total Jobs 
>>>>>>>>> 10 Jobs Created 
        List of jobs Created: 1-10 

crab:  You can also follow the status of this task on :
        CMS Dashboard: http://dashb-cms-job-task.cern.ch/taskmon.html#task=dlevans_T2_US_UCSD-test_210709_nq14w9
        Server page: http://glidein-2.t2.ucsd.edu:8888/logginfo
        Your task name is: dlevans_T2_US_UCSD-test_210709_nq14w9 

e.g. job is not submitting

web monitoring does not work I go to the web monitoring http://glidein-2.t2.ucsd.edu:8888/logginfo/ and look for my task, or any other task and find

List of All's tasks
Task name   Task status   Completeness    Show
Total number of tasks: 0 
 STEP09 Problems found with CRAB server

26/05/09

CRAB_2_5_1 unable to submit new ntuple making jobs in CMSSW_2_2_10. I do not know what is the cause of this problem but it is in my mind typical of the way CRAB spontaniously fails to work with some external change or another. It is apparently a known problem. Advise for the time being to use 2_6_0_pre3 +.

Changed:
<
<
*** Discussion title: CRAB Feedback

Hi Dave

On Tue, 26 May 2009 20:09:10 GMT, Eric Vaandering wrote:

> > From what I can tell there is no discrepancy. Your jobs are done, it
> > doesn't say they are done successfully. Once you do a -getoutput and
> > then -status again, you should see a non-zero EXE_EXIT_CODE
> >

in addition this is a bug already discussed (see also savannah #50798)
and fixed. It will be available in the next release (2_6_0). Actually
you can try the 2_6_0_pre3 () note it'a just a pre release.. so could
be not stable.

Daniele

(
)
https://hypernews.cern.ch/HyperNews/CMS/get/crabDevelopment/1062.html

>
>
* Discussion title: CRAB Feedback

Hi Dave

On Tue, 26 May 2009 20:09:10 GMT, Eric Vaandering wrote:

> > From what I can tell there is no discrepancy. Your jobs are done, it
> > doesn't say they are done successfully. Once you do a -getoutput and
> > then -status again, you should see a non-zero EXE_EXIT_CODE
> >

in addition this is a bug already discussed (see also savannah #50798)
and fixed. It will be available in the next release (2_6_0). Actually
you can try the 2_6_0_pre3 ( ) note it'a just a pre release.. so could
be not stable.

Daniele

(
)
https://hypernews.cern.ch/HyperNews/CMS/get/crabDevelopment/1062.html
  25/05/09
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback